Internet Explorer Document Mode(Compatible)’u Otomatik değiştirme

Browserlardaki versiyon farkları herkesin başına iş açmıştır.Özellikle explorer’da versiyonlar arasında bir çok tutarsızlık mevcut.Yaptığımız bir tasarımın kullanıcı tarafında kullanılan browser’ın en yüksek versiyonunda çalışması için bir meta tag mevcut aşağıda bunu sizlerle paylaşıyorum.

<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />

Örneğin web sitemizin internet explorer 8 uyumluluğunda çalışmasını istiyorsak aşağıdaki kodu kullanabiliriz.

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8" />